Chrome Extension (Beta) temporarily unavailable

Incident Report for Namecoach

Update

We're still working on the backend maintenance for the Chrome Extension (Beta). The extension remains temporarily offline, and no other Namecoach services are affected. We'll post an update here as soon as it's back. Thank you for your patience.
Posted Sep 01, 2026 - 18:33 UTC

Monitoring

We've temporarily taken our complimentary Chrome Extension (Beta) offline while we perform backend maintenance. No other Namecoach services are affected. The extension will be back soon — we'll post an update here as soon as it's available again. Thank you for your patience.
Posted Aug 17, 2026 - 23:01 UTC
This incident affects: Namecoach Free Chrome Extension.