Namecoach AI in Canvas

Incident Report for Namecoach

Resolved

Starting 8/31/2026, certain customers experienced abnormalities with audio and custom attribute updates within Namecoach AI for Canvas. We identified the root cause and deployed the resolution earlier this morning, 9/1.
Posted Sep 01, 2026 - 18:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 01, 2026 - 14:00 UTC

Identified

Certain customers experienced abnormalities with audio and custom attribute updates within Namecoach AI for Canvas
Posted Aug 31, 2026 - 18:08 UTC
This incident affected: Namecoach AI for Higher Education (Namecoach for Higher Education).