We have deployed a fix for the issue and are monitoring the results.
Posted Apr 02, 2025 - 16:56 UTC
Identified
We have identified that an update to our permissions structure has resulted in some users being unable to access Namepages to which they have been added as co-admins. We are working on rolling back the update that caused this issue and plan to resolve the issue by April 2.
Posted Apr 01, 2025 - 18:40 UTC
This incident affected: Namecoach for Higher Education (Namecoach for Higher Education).